On Wed, Apr 2, 2025 at 11:57 PM Hayato Kuroda (Fujitsu)
<kuroda.hayato@fujitsu.com> wrote:
>
> Dear Michael,
>
> > Maybe we don't need a short option at all for this, at least initially?
>
> Indeed, updated.
Thank you for updating the patch. Here are some minor comments:
The <option>--two-phase</option> can be specified with
<option>--create-slot</option> to enable decoding of prepared
transactions.
+ Also, <option>--falover</option> can be specified with
+ <option>--create-slot</option> to create replication slot which can be
+ synchronized to the standby.
How about rewording the whole sentence like:
+ The <option>--two-phase</option> and
<option>--failover</option> options
+ can be specified with <option>--create-slot</option>.
Explaining both options here seems redundant to me.
---
+ <para>
+ Allows created replication slot to be synchronized to the standbys.
+ This option may only be specified with <option>--create-slot</option>.
+ </para>
How about slightly rewording to like:
+ Enables the slot to be synchronized to the standbys. This
option may only be
+ specified with <option>--create-slot</option>.
Also, the descriptions of pg_recvlogical options are written in
alphabetical order. Please put the description for --failover option
after -E/--endpos.
The rest looks good to me.
Regards,
--
Masahiko Sawada
Amazon Web Services: https://aws.amazon.com