Re: TCP network cost

From: Linos
Subject: Re: TCP network cost
Date: ,
Msg-id: 49AAD1CF.6000908@linos.es
(view: Whole thread, Raw)
In response to: Re: TCP network cost  (Tom Lane)
Responses: Re: TCP network cost  (Tom Lane)
List: pgsql-performance

Tree view

TCP network cost  ("Ross J. Reedstrom", )
 Re: TCP network cost  (Rusty Conover, )
  Re: TCP network cost  (, )
  Re: TCP network cost  ("Ross J. Reedstrom", )
   Re: TCP network cost  (Rusty Conover, )
    Re: TCP network cost  ("Ross J. Reedstrom", )
     Re: TCP network cost  ("Ross J. Reedstrom", )
      Re: TCP network cost  (Aaron Turner, )
     Re: TCP network cost  (PFC, )
      Re: TCP network cost  ("Ross J. Reedstrom", )
   Re: TCP network cost  (Gregory Stark, )
    Re: TCP network cost  ("Ross J. Reedstrom", )
     Re: TCP network cost  (Tom Lane, )
      Re: TCP network cost  ("Ross J. Reedstrom", )
       Re: TCP network cost  (Linos, )
        Re: TCP network cost  (Tom Lane, )
         Re: TCP network cost  (Linos, )
          Re: TCP network cost  (Tom Lane, )
           Re: TCP network cost  (Linos, )
            Re: TCP network cost  (Tom Lane, )
             Re: TCP network cost  (Magnus Hagander, )
              Re: TCP network cost  (Linos, )
 Re: TCP network cost  (Aaron Turner, )

Tom Lane escribió:
> Linos <> writes:
>> Tom Lane escribió:
>>> Does that number include connection startup overhead?  (If it doesn't,
>>> it'd be pretty strange.)
>
>> This difference it is from the runtime of the query, i get this with \timing
>> parameter in psql,
>
> That's just weird --- ssl off should be ssl off no matter which knob you
> use to turn it off.  Are you sure it's really off in the slow connections?
>
>             regards, tom lane

Maybe i am missing something, i use the same command to connect to it from
localhost "psql -d database -h localhost" and in the pcap files i have captured
the protocol it is clear (with "ssl = false" or "ssl = true" either), but in the
debian machine with "ssl = true" in postgresql.conf you can see in the pcap file
big time jumps between data packets, psql commandline enables automatically ssl
if the server supports it? but if this is the case i should see encrypted
traffic in pcap files, and the problem should be the same in Arch Linux, no? If
you want that i make a local test explain me the steps and i will try here.

Regards,
Miguel Angel.


pgsql-performance by date:

From: "Cox, Brian"
Date:
Subject: Re: "slow" queries
From: Tom Lane
Date:
Subject: Re: "slow" queries