I wrote:
> Thomas Munro <thomas.munro@gmail.com> writes:
>> On Wed, May 13, 2020 at 3:16 AM Tom Lane <tgl@sss.pgh.pa.us> wrote:
>>> Hash/Batch/Allocating
>>> Hash/Batch/Electing
>>> Hash/Batch/Loading
>>> Hash/GrowBatches/Allocating
>> Perhaps we should also drop the 'ing' from the verbs, to be more like
>> ...Read etc.
> Yeah, that aspect was bothering me too. Comparing these to other
> wait event names, you could make a case for either "Allocate" or
> "Allocation"; but there are no other names with -ing.
After contemplating these for a bit, my proposal is to drop the
slashes and convert "verbing" to "verb", giving
HashBatchAllocate
HashBatchElect
HashBatchLoad
HashBuildAllocate
HashBuildElect
HashBuildHashInner
HashBuildHashOuter
HashGrowBatchesAllocate
HashGrowBatchesDecide
HashGrowBatchesElect
HashGrowBatchesFinish
HashGrowBatchesRepartition
HashGrowBucketsAllocate
HashGrowBucketsElect
HashGrowBucketsReinsert
In addition to that, I think the ClogGroupUpdate event needs to be renamed
to XactGroupUpdate, since we changed "clog" to "xact" in the exposed SLRU
and LWLock names.
(There are some other names that I wouldn't have picked in a green field,
but it's probably not worth the churn to change them.)
Also, as previously noted, ProcSignalBarrier should be in the IPC event
class not IO.
Barring objections, I'll make these things happen before beta1.
regards, tom lane