On Wed, Mar 06, 2024 at 10:02:43AM +0530, Bharath Rupireddy wrote:
> On Wed, Mar 6, 2024 at 1:22 AM Nathan Bossart <nathandbossart@gmail.com> wrote:
>> I was thinking of something more like
>>
>> typedef enum
>> {
>> NO_FORCE_SWITCH_TO_STREAMING, /* no switch necessary */
>> FORCE_SWITCH_TO_STREAMING_PENDING, /* exhausting pg_wal */
>> FORCE_SWITCH_TO_STREAMING, /* switch to streaming now */
>> } WALSourceSwitchState;
>>
>> At least, that illustrates my mental model of the process here. IMHO
>> that's easier to follow than two similarly-named bool variables.
>
> I played with that idea and it came out very nice. Please see the
> attached v22 patch. Note that personally I didn't like "FORCE" being
> there in the names, so I've simplified them a bit.
Thanks. I'd like to spend some time testing this, but from a glance, the
code appears to be in decent shape.
--
Nathan Bossart
Amazon Web Services: https://aws.amazon.com