Re: Avoiding upgrade backlash

From: Leif B. Kristensen
Subject: Re: Avoiding upgrade backlash
Date: ,
Msg-id: 200711141559.21957.leif@solumslekt.org
(view: Whole thread, Raw)
In response to: Re: Avoiding upgrade backlash  (Peter Eisentraut)
List: pgsql-advocacy

Tree view

Avoiding upgrade backlash  (Josh Berkus, )
 Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
 Re: Avoiding upgrade backlash  (Andrew Sullivan, )
  Re: Avoiding upgrade backlash  (Gregory Stark, )
   Re: Avoiding upgrade backlash  (Bruce Momjian, )
    Re: Avoiding upgrade backlash  (Andrew Sullivan, )
 Re: Avoiding upgrade backlash  (Peter Eisentraut, )
  Re: Avoiding upgrade backlash  (Stefan Kaltenbrunner, )
   Re: Avoiding upgrade backlash  (Bernd Helmle, )
  Re: Avoiding upgrade backlash  (Josh Berkus, )
   Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
    Re: [DOCS] Avoiding upgrade backlash  ("Joshua D. Drake", )
  Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
 Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
  Re: Avoiding upgrade backlash  (Alvaro Herrera <-ip.org>, )
   Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
    Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
     Re: Avoiding upgrade backlash  (Peter Eisentraut, )
      Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
       Re: Avoiding upgrade backlash  (Peter Eisentraut, )
        Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
     Re: Avoiding upgrade backlash  (Greg Smith, )
    Re: Avoiding upgrade backlash  (Jon Sime, )

On Wednesday 14. November 2007, Peter Eisentraut wrote:

> Certainly your statement from the Gentoo forum posting "The 8.2
> pg_dump won't do anything about those implicit casts, but the 8.3
> version will take care of a lot of potential problems with them."
> would be sheer magic and certainly don't correspond to anything
> implemented in pg_dump.

That may not have been explicitly said in the current discussion, but it
has certainly been my impression that so is the case. My apologies if
this is an unwarranted assumption.

If somebody would dispel my ignorance and explain _why_ we should use
the 8.3 pg_dump, I'd be very thankful.
--
Leif Biberg Kristensen | Registered Linux User #338009
http://solumslekt.org/ | Cruising with Gentoo/KDE
My Jazz Jukebox: http://www.last.fm/user/leifbk/


pgsql-advocacy by date:

From: "Marc G. Fournier"
Date:
Subject: Re: [pgsql-www] Gborg: announcement by 404
From: Shane Ambler
Date:
Subject: Re: Gborg: announcement by 404