Re: Avoiding upgrade backlash

From: Leif B. Kristensen
Subject: Re: Avoiding upgrade backlash
Date: ,
Msg-id: 200711141354.49400.leif@solumslekt.org
(view: Whole thread, Raw)
In response to: Re: Avoiding upgrade backlash  ("Leif B. Kristensen")
Responses: Re: Avoiding upgrade backlash  (Peter Eisentraut)
Re: Avoiding upgrade backlash  (Greg Smith)
List: pgsql-advocacy

Tree view

Avoiding upgrade backlash  (Josh Berkus, )
 Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
 Re: Avoiding upgrade backlash  (Andrew Sullivan, )
  Re: Avoiding upgrade backlash  (Gregory Stark, )
   Re: Avoiding upgrade backlash  (Bruce Momjian, )
    Re: Avoiding upgrade backlash  (Andrew Sullivan, )
 Re: Avoiding upgrade backlash  (Peter Eisentraut, )
  Re: Avoiding upgrade backlash  (Stefan Kaltenbrunner, )
   Re: Avoiding upgrade backlash  (Bernd Helmle, )
  Re: Avoiding upgrade backlash  (Josh Berkus, )
   Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
    Re: [DOCS] Avoiding upgrade backlash  ("Joshua D. Drake", )
  Re: [DOCS] Avoiding upgrade backlash  (Tom Lane, )
 Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
  Re: Avoiding upgrade backlash  (Alvaro Herrera <-ip.org>, )
   Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
    Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
     Re: Avoiding upgrade backlash  (Peter Eisentraut, )
      Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
       Re: Avoiding upgrade backlash  (Peter Eisentraut, )
        Re: Avoiding upgrade backlash  ("Leif B. Kristensen", )
     Re: Avoiding upgrade backlash  (Greg Smith, )
    Re: Avoiding upgrade backlash  (Jon Sime, )

On Wednesday 14. November 2007, Leif B. Kristensen wrote:
>On Tuesday 13. November 2007, Alvaro Herrera wrote:
>>Leif B. Kristensen wrote:
>>> On Monday 12. November 2007, Josh Berkus wrote:
>>> >I'm thinking that we need to warn everyone about:
>>> >1) They need to use 8.3's pg_dump, not the old version, to upgrade
>>>
>>> Isn't there a chicken-and-egg problem here? On my Gentoo system, I
>>> have always been forced to uninstall the old version before
>>> upgrading to a new version.
>>
>>That's a Gentoo shortcoming, nothing more.
>
>I've started a thread about it in the Portage & Programming section of
>forums.gentoo.org:
>
>http://forums.gentoo.org/viewtopic-t-615494.html
>
>I hope that someone more knowledgeable than me will be able to
>contribute in bringing this issue to the attention of the Gentoo
>developers, and hopefully work out a solution. Sure, there are other
>Gentoo users than me around here?

FYI, I've filed a bug report on bugs.gentoo.org:

"This is not quite a bug, but rather an approaching challenge. See this
thread on forums.gentoo.org
[http://forums.gentoo.org/viewtopic-t-615494.html], in which I was
asked to file a bug report. Concerning the upcoming PostgreSQL upgrade
from 8.2 to 8.3, it's imperative that Gentoo implements an adequate
transition procedure. Blocking the old version will create
a 'chicken-and-egg' situation where you are left incapable of upgrading
your existing databases. According to the developers, it's important
that a dump of the old database should be done with the new 8.3 version
of pg_dump. See this thread
[http://archives.postgresql.org/pgsql-advocacy/2007-11/msg00051.php] on
pgsql-advocacy for some details."

The bug id is [https://bugs.gentoo.org/show_bug.cgi?id=199142].
--
Leif Biberg Kristensen | Registered Linux User #338009
http://solumslekt.org/ | Cruising with Gentoo/KDE
My Jazz Jukebox: http://www.last.fm/user/leifbk/


pgsql-advocacy by date:

From: Bruce Momjian
Date:
Subject: Re: [pgsql-www] Gborg: announcement by 404
From: Robert Treat
Date:
Subject: Re: [pgsql-www] Gborg: announcement by 404