Re: renaming "storage parameters" - Mailing list pgsql-hackers

From Tom Lane
Subject Re: renaming "storage parameters"
Date
Msg-id 18391.1234202956@sss.pgh.pa.us
Whole thread Raw
In response to renaming "storage parameters"  (Alvaro Herrera <alvherre@commandprompt.com>)
List pgsql-hackers
Alvaro Herrera <alvherre@commandprompt.com> writes:
> Euler Taveira is arguing in an autovacuum thread that we should give
> "storage parameters" a different name; his argument is that
> "autovacuum_enabled" is not really a parameter that relates to storage.
> He is proposing "relation parameters".

> I am against the idea of renaming them, for two reasons: 1. it's a
> user-visible change that doesn't seem to buy a lot; 2. it's a tedious
> patch to write.

> Can I get some votes?

I agree with leaving them alone.  "Storage" might not be exactly le mot
juste anymore but it still gives you a good idea what they're meant for;
in particular that they are targeted at implementation concerns rather
than SQL-level semantics of the table.  Moving to a content-free name
like "relation parameter" in order to cover all possible uses doesn't
seem like it helps anyone understand anything better.
        regards, tom lane


pgsql-hackers by date:

Previous
From: Tom Lane
Date:
Subject: Re: WIP: fix SET WITHOUT OIDS, add SET WITH OIDS
Next
From: Andrew Dunstan
Date:
Subject: Re: WIP: fix SET WITHOUT OIDS, add SET WITH OIDS