shihao zhong <zhong950419@gmail.com> wrote:
> One more for 0008, for your next version.
>
> finalize_block_range() moves *range_start_dst_p before the replay. If the replay adds pages to the new heap, the next
update_identity_index
> () indexes those rows again. REPACK then fails with a duplicate key error.
Right, I've noticed that earlier this week when addressing your other
findings. The fix will be included in the next version. Thanks.
--
Antonin Houska
Web: https://www.cybertec-postgresql.com