Re: cannot "make USE_PGXS=1" b/c no pgxs.mk exists

From: Jonathan Brinkman
Subject: Re: cannot "make USE_PGXS=1" b/c no pgxs.mk exists
Date: ,
Msg-id: 003e01cc3b22$76398630$62ac9290$@com
(view: Whole thread, Raw)
In response to: Re: cannot "make USE_PGXS=1" b/c no pgxs.mk exists  ("Albe Laurenz")
List: pgsql-general

Thanks for your reply

yes I did install libpq-dev, which was installed (instead) when I tried to
run this in Ubuntu 10.04LTS:
Sudo apt-get install postgresql-dev
It gave a message that postgresql-dev was replaced by libpq-dev...

But that installation did not install the files including
/usr/lib/postgresql/8.4/lib/pgxs/src/makefiles/pgxs.mk



-----Original Message-----
From: Albe Laurenz [mailto:]
Sent: Tuesday, July 05, 2011 4:19 AM
To: ; 
Subject: RE: [GENERAL] cannot "make USE_PGXS=1" b/c no pgxs.mk exists

Jonathan Brinkman wrote:
> Makefile:12: /usr/lib/postgresql/8.4/lib/pgxs/src/makefiles/pgxs.mk:
No such
> file or directory

Maybe you have to install the software package that contains
PostgreSQL's
development environment.

Yours,
Laurenz Albe



pgsql-general by date:

From: c k
Date:
Subject: Re: [ADMIN] Python UCS4 error
From: John R Pierce
Date:
Subject: Re: [ADMIN] Python UCS4 error