diff --git a/doc/src/sgml/advanced.sgml b/doc/src/sgml/advanced.sgml
index 3286c2cf0b2..6c2ca4aaead 100644
--- a/doc/src/sgml/advanced.sgml
+++ b/doc/src/sgml/advanced.sgml
@@ -258,8 +258,8 @@ COMMIT;
- When an error occurs within a transaction block the transaction is not
- ended, but instead goes into an aborted state. While in this state all
+ When an error occurs within a transaction block, the transaction is not
+ ended but instead goes into an aborted state. While in this state, all
commands except and
are rejected. Importantly, both those
commands will behave identically — they roll back and close the
diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
index 0165eb9ec02..ee62a3084b4 100644
--- a/doc/src/sgml/config.sgml
+++ b/doc/src/sgml/config.sgml
@@ -1775,7 +1775,7 @@ include_dir 'conf.d'
- Enables SNI configuration for SSL connections. When set to on
+ Enables SNI configuration for SSL connections. When set to on,
host configuration from is used, see
for more details.
@@ -3040,7 +3040,7 @@ include_dir 'conf.d'
Sets the time after which entirely idle I/O worker processes exit, reducing the
- size of pool to match demand. The default is 1 minute. This
+ size of the pool to match demand. The default is 1 minute. This
parameter can only be set in the
postgresql.conf file or on the server command
line.
@@ -7971,7 +7971,7 @@ local0.* /var/log/postgresql
- Causes analyze action executed by autovacuum to be logged if it ran for at
+ Causes each analyze action executed by autovacuum to be logged if it ran for at
least the specified amount of time. Setting this to zero logs
all analyze actions by autovacuum. -1 disables logging
analyze actions by autovacuum. If this value is specified without units,
diff --git a/doc/src/sgml/fdwhandler.sgml b/doc/src/sgml/fdwhandler.sgml
index 502441fefcb..691d6ac4532 100644
--- a/doc/src/sgml/fdwhandler.sgml
+++ b/doc/src/sgml/fdwhandler.sgml
@@ -1429,14 +1429,14 @@ ImportForeignStatistics(Relation relation,
level to use.
If the function imports the statistics successfully, it should return
true. Otherwise, return false, in
- which case AnalyzeForeignTable callback function is
+ which case the AnalyzeForeignTable callback function is
called on the foreign table to generate statistics locally, if supported.
For reference, the logic for calculating statistics in
PostgreSQL is found in
- src/backend/command/analyze.c.
+ src/backend/commands/analyze.c.
It's recommended to import table-level and column-level statistics for the
foreign table using import_relation_statistics,
import_attribute_statistics, and
diff --git a/doc/src/sgml/func/func-admin.sgml b/doc/src/sgml/func/func-admin.sgml
index 64b0e7bb972..6148654e717 100644
--- a/doc/src/sgml/func/func-admin.sgml
+++ b/doc/src/sgml/func/func-admin.sgml
@@ -1492,7 +1492,7 @@ postgres=# SELECT '0/0'::pg_lsn + pd.segment_number * ps.setting::int + :offset
void
- Synchronize the logical failover replication slots from the primary
+ Synchronizes the logical failover replication slots from the primary
server to the standby server. This function can only be executed on the
standby server. Temporary synced slots, if any, cannot be used for
logical decoding and must be dropped after promotion. This function
diff --git a/doc/src/sgml/func/func-aggregate.sgml b/doc/src/sgml/func/func-aggregate.sgml
index 6a6a4d7e32e..7357bcb7d76 100644
--- a/doc/src/sgml/func/func-aggregate.sgml
+++ b/doc/src/sgml/func/func-aggregate.sgml
@@ -432,7 +432,7 @@
are coerced to text; value arguments are converted as per
to_json or to_jsonb.
The key cannot be null. If the
- value is null then the entry is skipped,
+ value is null, then the entry is skipped.
No
@@ -461,7 +461,7 @@
are coerced to text; value arguments are converted as per
to_json or to_jsonb.
Values can be null, but keys cannot.
- If there is a duplicate key an error is thrown.
+ If there is a duplicate key, an error is thrown.
No
@@ -490,8 +490,8 @@
are coerced to text; value arguments are converted as per
to_json or to_jsonb.
The key cannot be null. If the
- value is null then the entry is skipped.
- If there is a duplicate key an error is thrown.
+ value is null, then the entry is skipped.
+ If there is a duplicate key, an error is thrown.
No
diff --git a/doc/src/sgml/func/func-array.sgml b/doc/src/sgml/func/func-array.sgml
index 7f162bd7670..24efef60bc6 100644
--- a/doc/src/sgml/func/func-array.sgml
+++ b/doc/src/sgml/func/func-array.sgml
@@ -145,7 +145,7 @@
shows the functions
available for use with array types. See
- for more information and examples of the use of these functions.
+ for more information and examples of the use of these functions.
diff --git a/doc/src/sgml/func/func-json.sgml b/doc/src/sgml/func/func-json.sgml
index f8ff4355a31..3a24b8ef44f 100644
--- a/doc/src/sgml/func/func-json.sgml
+++ b/doc/src/sgml/func/func-json.sgml
@@ -2789,7 +2789,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String converted to all lower case according to the rules of the database's locale.
+ String converted to all lower case according to the rules of the database's locale
jsonb_path_query('"TOM"', '$.lower()')
@@ -2803,7 +2803,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String converted to all upper case according to the rules of the database's locale.
+ String converted to all upper case according to the rules of the database's locale
jsonb_path_query('"tom"', '$.upper()')
@@ -2819,7 +2819,7 @@ ERROR: jsonpath member accessor can only be applied to an object
String with the first letter of each word converted to upper case
according to the rules of the database's locale. Words are sequences
- of alphanumeric characters separated by non-alphanumeric characters.
+ of alphanumeric characters separated by non-alphanumeric characters
jsonb_path_query('"hi THOMAS"', '$.initcap()')
@@ -2833,7 +2833,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String with all occurrences of substring from replaced with substring to.
+ String with all occurrences of substring from replaced with substring to
jsonb_path_query('"abcdefabcdef"', '$.replace("cd", "XX")')
@@ -2850,7 +2850,7 @@ ERROR: jsonpath member accessor can only be applied to an object
String split at occurrences of delimiter
and returns the n'th field (counting from
one) or, when n is negative, returns the
- |n|'th-from-last field.
+ |n|'th-from-last field
jsonb_path_query('"abc~@~def~@~ghi"', '$.split_part("~@~", 2)')
@@ -2868,7 +2868,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String with the longest string containing only spaces or the
+ String with the longest substring containing only spaces or the
characters in characters removed from the
start of string
@@ -2888,7 +2888,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String with the longest string containing only spaces or the
+ String with the longest substring containing only spaces or the
characters in characters removed from the
end of string
@@ -2908,7 +2908,7 @@ ERROR: jsonpath member accessor can only be applied to an object
string
- String with the longest string containing only spaces or the
+ String with the longest substring containing only spaces or the
characters in characters removed from the
start and end of string
@@ -3318,7 +3318,7 @@ $.* ? (@ like_regex "^\\d+$")
SQL/JSON functions JSON_EXISTS(),
JSON_QUERY(), and JSON_VALUE()
described in can be used
- to query JSON documents. Each of these functions apply a
+ to query JSON documents. Each of these functions applies a
path_expression (an SQL/JSON path query) to a
context_item (the document). See
for more details on what
diff --git a/doc/src/sgml/func/func-matching.sgml b/doc/src/sgml/func/func-matching.sgml
index ae1dff66722..fd5410db97d 100644
--- a/doc/src/sgml/func/func-matching.sgml
+++ b/doc/src/sgml/func/func-matching.sgml
@@ -2337,7 +2337,7 @@ SELECT regexp_match('abc01234xyz', '(?:(.*?)(\d+)(.*)){1,1}');
Since SQL:2008, the SQL standard includes regular expression operators
- and functions that performs pattern
+ and functions that perform pattern
matching according to the XQuery regular expression
standard:
diff --git a/doc/src/sgml/glossary.sgml b/doc/src/sgml/glossary.sgml
index d28a3729188..722f742db19 100644
--- a/doc/src/sgml/glossary.sgml
+++ b/doc/src/sgml/glossary.sgml
@@ -593,9 +593,9 @@
A set of
background worker
- processes which can enable or disable data checksums in a running cluster.
- The process which coordinates the work is known as the
- data checksums launcher and the process which
+ processes that can enable or disable data checksums in a running cluster.
+ The process that coordinates the work is known as the
+ data checksums launcher and the process that
operates on the individual databases is known as the
data checksums worker.
diff --git a/doc/src/sgml/libpq.sgml b/doc/src/sgml/libpq.sgml
index 68487a3954f..657d3702606 100644
--- a/doc/src/sgml/libpq.sgml
+++ b/doc/src/sgml/libpq.sgml
@@ -10572,7 +10572,7 @@ PGOAUTHDEBUG=UNSAFE legacy format; enables
Prints the total number of calls to the flow plugin to standard error
- when the OAuth flow completes. This helps developers debug the async
+ when the OAuth flow completes. This helps developers debug asynchronous
callback behavior.
diff --git a/doc/src/sgml/logical-replication.sgml b/doc/src/sgml/logical-replication.sgml
index 4701a3d9d18..c6a7aa9b20e 100644
--- a/doc/src/sgml/logical-replication.sgml
+++ b/doc/src/sgml/logical-replication.sgml
@@ -2876,7 +2876,7 @@ CONTEXT: processing remote data for replication origin "pg_16395" during "INSER
retain_dead_tuples
is enabled, the upgraded subscriber may be unable to detect conflicts or
log relevant commit timestamps and origins when applying changes from the
- publisher occurred before the upgrade. Additionally, immediately after the
+ publisher that occurred before the upgrade. Additionally, immediately after the
upgrade, the vacuum may remove the deleted rows that are required for
conflict detection. This can affect the changes that were not replicated
before the upgrade. To ensure consistent conflict tracking, users should
diff --git a/doc/src/sgml/logicaldecoding.sgml b/doc/src/sgml/logicaldecoding.sgml
index 6dc49108997..11723c1424e 100644
--- a/doc/src/sgml/logicaldecoding.sgml
+++ b/doc/src/sgml/logicaldecoding.sgml
@@ -674,7 +674,7 @@ DETAIL: Synchronization could lead to data loss, because the remote slot needs
A comma-separated list of publication names to subscribe to.
The individual publication names are treated
- as standard objects names and can be quoted the same as needed.
+ as standard object names and can be quoted the same as needed.
At least one publication name is required.
@@ -734,7 +734,7 @@ DETAIL: Synchronization could lead to data loss, because the remote slot needs
Enables sending two-phase transactions.
- Minimum protocol version 3 is required to turn it on.
+ This requires protocol version 3 or higher.
The default is off.
diff --git a/doc/src/sgml/maintenance.sgml b/doc/src/sgml/maintenance.sgml
index 137175ca3b5..80663d40137 100644
--- a/doc/src/sgml/maintenance.sgml
+++ b/doc/src/sgml/maintenance.sgml
@@ -855,7 +855,7 @@ HINT: Execute a database-wide VACUUM in that database.
running UPDATE statements with foreign key checks,
concurrent SELECT FOR SHARE operations, or frequent
use of savepoints causing lock contention.
- If oldest_multixact value remains unchanged while
+ If the oldest_multixact value remains unchanged while
num_members grows, it could indicate that long-running
transactions are preventing cleanup, or autovacuum is
not keeping up with the workload.
@@ -1180,7 +1180,7 @@ analyze threshold = analyze base threshold + analyze scale factor * number of tu
PostgreSQL 19 (i.e., the order the tables are
listed in the pg_class system catalog), set all of the
aforementioned "weight" parameters to 0.0. Otherwise,
- these "weight" parameters are multiplied to their respective component
+ these "weight" parameters are multiplied by their respective component
scores. For example, raising
to
2.0 effectively doubles the
diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgml
index 0d038de1a23..b5c3c7f451d 100644
--- a/doc/src/sgml/monitoring.sgml
+++ b/doc/src/sgml/monitoring.sgml
@@ -4849,7 +4849,7 @@ description | Waiting for a newly initialized WAL file to reach durable storage
relidoid
- Oid of the table.
+ OID of the table.
@@ -7095,7 +7095,7 @@ FROM pg_stat_get_backend_idset() AS backendid;
Number of tuples skipped because they contain malformed data.
This counter only advances when
- ignore is specified to the ON_ERROR
+ ignore is specified for the ON_ERROR
option.
diff --git a/doc/src/sgml/oauth-validators.sgml b/doc/src/sgml/oauth-validators.sgml
index 6c4a4f94769..1071115a355 100644
--- a/doc/src/sgml/oauth-validators.sgml
+++ b/doc/src/sgml/oauth-validators.sgml
@@ -117,7 +117,7 @@
That is, "trusted" in the sense that the OAuth client and the
PostgreSQL server are controlled by the same
entity. Notably, the Device Authorization client flow supported by
- libpq does not usually meet this bar, since it's designed for use by
+ libpq does not usually meet this bar, since it is designed for use by
public/untrusted clients.
@@ -433,7 +433,7 @@ typedef struct ValidatorModuleResult
Shutdown Callback
- The shutdown_cb callback is executed when the server
+ The shutdown_cb callback is executed when the
backend has finished validating tokens for the connection. If the validator
module has any allocated state, this callback should free it to avoid
resource leaks.
@@ -505,7 +505,7 @@ void RegisterOAuthHBAOptions(ValidatorModuleState *state, int num,
/*
- * Retrieve the string value of an HBA option which was registered via
+ * Retrieve the string value of an HBA option, which was registered via
* RegisterOAuthHBAOptions(). Usable only during validate_cb or shutdown_cb.
*
* If the user has set the corresponding option in pg_hba.conf, this function
@@ -554,7 +554,7 @@ const char *GetOAuthHBAOption(const ValidatorModuleState *state,
If a module finds an invalid option value during validate_cb,
- it's recommended to signal
+ it is recommended to signal
an internal error by setting result->error_detail
to a description of the problem and returning false.
diff --git a/doc/src/sgml/oid2name.sgml b/doc/src/sgml/oid2name.sgml
index 9340d7376aa..59e59613cd8 100644
--- a/doc/src/sgml/oid2name.sgml
+++ b/doc/src/sgml/oid2name.sgml
@@ -93,7 +93,7 @@
include system objects (those in
- ,
+ , ,
and schemas).
@@ -118,7 +118,7 @@
display more information about each object shown: tablespace name,
- schema name, OID and path.
+ schema name, OID, and path.
@@ -176,7 +176,7 @@
To display specific tables, select which tables to show by
- using , and/or .
+ using , , and/or .
takes an OID,
takes a filenode,
and takes a table name (actually, it's a LIKE
@@ -227,7 +227,7 @@
The environment variable PG_COLOR specifies whether to use
color in diagnostic messages. Possible values are
- always, auto and
+ always, auto, and
never.
diff --git a/doc/src/sgml/parallel.sgml b/doc/src/sgml/parallel.sgml
index af43484703e..e1731fb3b66 100644
--- a/doc/src/sgml/parallel.sgml
+++ b/doc/src/sgml/parallel.sgml
@@ -301,8 +301,8 @@ EXPLAIN SELECT * FROM pgbench_accounts WHERE filler LIKE '%x%';
- In a parallel tid range scan, the range of blocks
- will be subdivided into smaller ranges which are shared among the
+ In a parallel TID range scan, the range of blocks
+ will be subdivided into smaller ranges, which are shared among the
cooperating processes. Each worker process will complete the scanning
of its given range of blocks before requesting an additional range of
blocks.
diff --git a/doc/src/sgml/pgbuffercache.sgml b/doc/src/sgml/pgbuffercache.sgml
index 1e9aee10275..d009c49e65b 100644
--- a/doc/src/sgml/pgbuffercache.sgml
+++ b/doc/src/sgml/pgbuffercache.sgml
@@ -56,19 +56,19 @@
- This module provides the pg_buffercache_pages()
- function (wrapped in the pg_buffercache view), the
- pg_buffercache_os_pages() function (wrapped in the
+ This module provides the following functions: pg_buffercache_pages()
+ (wrapped in the pg_buffercache view),
+ pg_buffercache_os_pages() (wrapped in the
pg_buffercache_os_pages and
- pg_buffercache_numa views), the
- pg_buffercache_summary() function, the
- pg_buffercache_usage_counts() function, the
- pg_buffercache_evict() function, the
- pg_buffercache_evict_relation() function, the
- pg_buffercache_evict_all() function, the
- pg_buffercache_mark_dirty() function, the
- pg_buffercache_mark_dirty_relation() function and the
- pg_buffercache_mark_dirty_all() function.
+ pg_buffercache_numa views),
+ pg_buffercache_summary(),
+ pg_buffercache_usage_counts(),
+ pg_buffercache_evict(),
+ pg_buffercache_evict_relation(),
+ pg_buffercache_evict_all(),
+ pg_buffercache_mark_dirty(),
+ pg_buffercache_mark_dirty_relation(), and
+ pg_buffercache_mark_dirty_all().
@@ -80,7 +80,7 @@
The pg_buffercache_os_pages() function provides OS
- pages mappings for shared buffer entries. When its argument is
+ page mappings for shared buffer entries. When its argument is
true, it also provides NUMA node
mappings for shared buffer entries (this information is not part of
pg_buffercache_pages() itself, as it is much
@@ -626,10 +626,10 @@
column of the pg_buffercache view. It returns
information about whether the buffer was marked as dirty.
The buffer_dirtied column is true on success,
- and false if the buffer was already dirty if the buffer was not valid or
+ and false if the buffer was already dirty, if the buffer was not valid, or
if it could not be marked as dirty because it was pinned.
The buffer_already_dirty column is true if
- the buffer couldn't be marked as dirty because it was already dirty. The
+ the buffer could not be marked as dirty because it was already dirty. The
result is immediately out of date upon return, as the buffer might become
valid again at any time due to concurrent activity. The function is
intended for developer testing only.
@@ -647,7 +647,7 @@
relation identifier instead of buffer identifier. It tries to mark all
buffers dirty for all forks in that relation.
It returns the number of buffers marked as dirty, the number of buffers
- already dirty and the number of buffers skipped because already pinned or
+ already dirty, and the number of buffers skipped because they are already pinned or
invalid.
The result is immediately out of date upon return, as the buffer might
become valid again at any time due to concurrent activity. The function is
@@ -665,7 +665,7 @@
pg_buffercache_mark_dirty_all() tries to mark all
buffers dirty in the buffer pool.
It returns the number of buffers marked as dirty, the number of buffers
- already dirty and the number of buffers skipped because already pinned or
+ already dirty, and the number of buffers skipped because already pinned or
invalid.
The result is immediately out of date upon return, as the buffer might
become valid again at any time due to concurrent activity. The function is
diff --git a/doc/src/sgml/pgplanadvice.sgml b/doc/src/sgml/pgplanadvice.sgml
index 4592a5ced54..2a0883aeb4c 100644
--- a/doc/src/sgml/pgplanadvice.sgml
+++ b/doc/src/sgml/pgplanadvice.sgml
@@ -84,9 +84,9 @@ EXPLAIN (COSTS OFF, PLAN_ADVICE)
Once you have an advice string for a query, you can use it to control how
that query is planned. You can do this by setting
- pg_plan_advice.advice to the advice string you've
+ pg_plan_advice.advice to the advice string you have
chosen. This can be an advice string that was generated by the system,
- or one you've written yourself. One good way of creating your own advice
+ or one you have written yourself. One good way of creating your own advice
string is to take the string generated by the system and pick out just
those elements that you wish to enforce. In the example above,
pg_plan_advice emits advice for the join order, the
@@ -142,15 +142,15 @@ EXPLAIN (COSTS OFF)
planner still fails to produce the desired plan, this means that either
there is a bug in your advice string, or the plan in question was not
considered viable by the core planner. This commonly happens for one of two
- reasons. First, it might be that the planner believes that the plan you're
- trying to force would be semantically incorrect - that is, it would produce
- the wrong results - and for that reason it wasn't considered. Second, it
+ reasons. First, it might be that the planner believes that the plan you are
+ trying to force would be semantically incorrect, that is, it would produce
+ the wrong results, and for that reason it was not considered. Second, it
might be that the planner rejected the plan you were hoping to generate on
some grounds other than cost. For example, given a very simple query such as
SELECT * FROM some_table, the query planner will
decide that the use of an index is worthless here before it performs any
costing calculations. You cannot force it to use an index for this query
- even if you set enable_seqscan = false, and you can't
+ even if you set enable_seqscan = false, and you cannot
force it to use an index using plan advice, either.
@@ -182,9 +182,9 @@ EXPLAIN (COSTS OFF)
Because neither f nor d is the
first table in the JOIN_ORDER() specification, the
planner disables all direct joins between the two of them, thinking that
- the join to x should happen first. Since planning isn't
+ the join to x should happen first. Since planning is not
allowed to fail, a disabled plan between the two relations is eventually
- selected anyway, but here it's a Nested Loop rather than
+ selected anyway, but here it is a Nested Loop rather than
the Hash Join that was chosen in the above example where
no advice was specified. There are several different ways that this kind
of thing can happen; when it does, the resulting plan is generally worse
@@ -402,7 +402,7 @@ join_method_name(join_method_item [ ... ])
( advice_target [ ... ] ) }
- Join method advice specifies the relation, or set of relations, that should
+ Join method advice specifies the relation or set of relations that should
appear on the inner side of a join using the named join method. For
example, HASH_JOIN(a b) means that each of
a and b should appear on the inner
@@ -504,14 +504,14 @@ NO_GATHER(advice_target [ ... ])
NO_GATHER specifies that no Gather or
Gather Merge node should appear above any of the
targets, but it only constrains the planning of an individual subquery,
- and outer subquery levels can still use parallel query. For example,
+ and outer subquery levels can still use parallel queries. For example,
NO_GATHER(inner_example@any_1) precludes using a
Parallel Seq Scan to access the
inner_example table within the any_1
subquery, but it does not prevent the planner from placing
SubPlan any_1 beneath a Gather
or Gather Merge node. The following plan is
- compatible with NO_GATHER(inner_example@any_1), but
+ compatible with NO_GATHER(inner_example@any_1) but
not with NO_GATHER(outer_example):
@@ -624,7 +624,7 @@ EXPLAIN (COSTS OFF)
not matched means that none of the
specified advice targets were observed during query planning. This may
- happen if the advice simply doesn't match the query, or it may
+ happen if the advice does not match the query, or it may
occur if the relevant portion of the query was not planned, perhaps
because it was gated by a condition that was simplified to constant false.
@@ -691,8 +691,7 @@ EXPLAIN (COSTS OFF)
- pg_plan_advice.advice is an advice string to be
- used during query planning.
+ Specifies an advice string to be used during query planning.
@@ -707,8 +706,7 @@ EXPLAIN (COSTS OFF)
- pg_plan_advice.always_explain_supplied_advice causes
- EXPLAIN to always show any supplied advice and the
+ Causes EXPLAIN to always show any supplied advice and the
associated
advice feedback.
The default value is true. If set to
@@ -728,8 +726,7 @@ EXPLAIN (COSTS OFF)
- pg_plan_advice.always_store_advice_details allows
- EXPLAIN to show details related to plan advice even
+ Allows EXPLAIN to show details related to plan advice even
when prepared queries are used. The default value is
false. When planning a prepared query, it is not
possible to know whether EXPLAIN will later be used,
@@ -754,7 +751,7 @@ EXPLAIN (COSTS OFF)
- When set to true, pg_plan_advice.feedback_warnings
+ When set to true, this parameter
emits a warning whenever supplied plan advice is not successfully
enforced. The default value is false.
@@ -771,9 +768,8 @@ EXPLAIN (COSTS OFF)
- When pg_plan_advice.trace_mask is
- true, pg_plan_advice will print
- messages during query planning each time that
+ When this parameter is true, pg_plan_advice
+ will print messages during query planning each time that
pg_plan_advice alters the mask of allowable query
plan types in response to supplied plan advice. The default value is
false. The messages printed by this setting are not
diff --git a/doc/src/sgml/pgstashadvice.sgml b/doc/src/sgml/pgstashadvice.sgml
index 7813d63d91e..bee31fcc58b 100644
--- a/doc/src/sgml/pgstashadvice.sgml
+++ b/doc/src/sgml/pgstashadvice.sgml
@@ -58,7 +58,7 @@
show the query ID, and the PLAN_ADVICE option will
show plan advice. Query identifiers can also be obtained through tools
such as or
- , but these tools
+ pg_stat_activity, but these tools
will not provide plan advice strings. Note that
must be enabled for query
identifiers to be computed; if set to auto, loading
@@ -102,7 +102,7 @@
- Creates a new, empty advice stash with the given name.
+ Creates a new empty advice stash with the given name.
diff --git a/doc/src/sgml/protocol.sgml b/doc/src/sgml/protocol.sgml
index 8ced69f283b..aba34a82133 100644
--- a/doc/src/sgml/protocol.sgml
+++ b/doc/src/sgml/protocol.sgml
@@ -6184,7 +6184,7 @@ psql "dbname=postgres replication=database" -c "IDENTIFY_SYSTEM;"
The protocol version number. The most significant 16 bits are
the major version number. The least significant 16 bits are the minor
- version number. As an example protocol version 3.2 is represented as
+ version number. As an example, protocol version 3.2 is represented as
196610 in decimal or more clearly as
0x00030002 in hexadecimal.
diff --git a/doc/src/sgml/ref/alter_publication.sgml b/doc/src/sgml/ref/alter_publication.sgml
index 86bdc98fd09..6f79b2d39e2 100644
--- a/doc/src/sgml/ref/alter_publication.sgml
+++ b/doc/src/sgml/ref/alter_publication.sgml
@@ -127,7 +127,7 @@ ALTER PUBLICATION name RENAME TO ADD TABLES IN SCHEMA,
SET TABLES IN SCHEMA, SET ALL TABLES,
- and SET ALL SEQUENCES to a publication requires the
+ and SET ALL SEQUENCES to a publication require the
invoking user to be a superuser.
To alter the owner, you must be able to SET ROLE to the
new owning role, and that role must have CREATE
diff --git a/doc/src/sgml/ref/alter_subscription.sgml b/doc/src/sgml/ref/alter_subscription.sgml
index 545264e8a0a..37ba3fd2d9f 100644
--- a/doc/src/sgml/ref/alter_subscription.sgml
+++ b/doc/src/sgml/ref/alter_subscription.sgml
@@ -181,7 +181,7 @@ ALTER SUBSCRIPTION name RENAME TO <
The system catalog pg_subscription_rel
- is updated to record all tables and sequences known to the subscription,
+ is updated to record all tables and sequences known to the subscription
that are still part of the publication.
diff --git a/doc/src/sgml/ref/create_publication.sgml b/doc/src/sgml/ref/create_publication.sgml
index 8196e6a4235..0b03a6a62ab 100644
--- a/doc/src/sgml/ref/create_publication.sgml
+++ b/doc/src/sgml/ref/create_publication.sgml
@@ -203,7 +203,7 @@ CREATE PUBLICATION name
Marks the publication as one that replicates changes for all tables in
the database, including tables created in the future. Tables listed in
- EXCEPT clause are excluded from the publication.
+ the EXCEPT clause are excluded from the publication.
@@ -249,7 +249,7 @@ CREATE PUBLICATION name
For partitioned tables, only the root partitioned table may be specified
in EXCEPT. Doing so excludes the root table and
all of its partitions from replication. The optional
- ONLY and * has no effect for
+ ONLY and * have no effect for
partitioned tables.
diff --git a/doc/src/sgml/ref/pg_createsubscriber.sgml b/doc/src/sgml/ref/pg_createsubscriber.sgml
index 193f60628bc..5d501147608 100644
--- a/doc/src/sgml/ref/pg_createsubscriber.sgml
+++ b/doc/src/sgml/ref/pg_createsubscriber.sgml
@@ -153,14 +153,14 @@ PostgreSQL documentation
- pg_createsubscriber_server.log which captures logs
+ pg_createsubscriber_server.log, which captures logs
related to stopping and starting the standby server,
- pg_createsubscriber_internal.log which captures
- internal diagnostic output (validations, checks, etc.)
+ pg_createsubscriber_internal.log, which captures
+ internal diagnostic output (validations, checks, etc.).
@@ -327,7 +327,7 @@ PostgreSQL documentation
If a specified publication already exists on the publisher, it is reused.
It is useful to partially replicate the database if the specified
publication includes a list of tables. If the publication does not exist,
- it is automatically created with FOR ALL TABLES. Use
+ it is automatically created with FOR ALL TABLES. Use the
option to preview which publications will be
reused and which will be created.
@@ -575,7 +575,7 @@ PostgreSQL documentation
pg_createsubscriber terminates if recovery
does not end until the given number of seconds. Upon completion, the
included configuration file is renamed to
- pg_createsubscriber.conf.disabled so as it is no
+ pg_createsubscriber.conf.disabled so that it is no
longer loaded on subsequent restarts.
diff --git a/doc/src/sgml/ref/pgarchivecleanup.sgml b/doc/src/sgml/ref/pgarchivecleanup.sgml
index 79e751381ac..5edcac33f54 100644
--- a/doc/src/sgml/ref/pgarchivecleanup.sgml
+++ b/doc/src/sgml/ref/pgarchivecleanup.sgml
@@ -23,8 +23,8 @@ PostgreSQL documentation
pg_archivecleanupoption
- archivelocation
- oldestkeptwalfile
+ archive_location
+ oldest_kept_wal_file
@@ -44,28 +44,28 @@ PostgreSQL documentation
server to use pg_archivecleanup, put this into its
postgresql.conf configuration file:
-archive_cleanup_command = 'pg_archivecleanup archivelocation "%r"'
+archive_cleanup_command = 'pg_archivecleanup archive_location "%r"'
- where archivelocation is the directory from which WAL segment
+ where archive_location is the directory from which WAL segment
files should be removed.
When used within , all WAL files
logically preceding the value of the %r argument will be removed
- from archivelocation. This minimizes the number of files
+ from archive_location. This minimizes the number of files
that need to be retained, while preserving crash-restart capability. Use of
- this parameter is appropriate if the archivelocation is a
+ this parameter is appropriate if the archive_location is a
transient staging area for this particular standby server, but
- not when the archivelocation is intended as a
+ not when the archive_location is intended as a
long-term WAL archive area, or when multiple standby servers are recovering
from the same archive location.
When used as a standalone program all WAL files logically preceding the
- oldestkeptwalfile will be removed from archivelocation.
+ oldest_kept_wal_file will be removed from archive_location.
In this mode, if you specify a .partial or .backup
file name, then only the file prefix will be used as the
- oldestkeptwalfile. This treatment of .backup
+ oldest_kept_wal_file. This treatment of .backup
file name allows you to remove
all WAL files archived prior to a specific base backup without error.
For example, the following example will remove all files older than
@@ -80,7 +80,7 @@ pg_archivecleanup: removing file "archive/00000001000000370000000E"
pg_archivecleanup assumes that
- archivelocation is a directory readable and writable by the
+ archive_location is a directory readable and writable by the
server-owning user.
diff --git a/doc/src/sgml/ref/pgbench.sgml b/doc/src/sgml/ref/pgbench.sgml
index 9688527c955..d941451c15e 100644
--- a/doc/src/sgml/ref/pgbench.sgml
+++ b/doc/src/sgml/ref/pgbench.sgml
@@ -815,7 +815,7 @@ pgbench optionsd
deadlock failures;
- other failures;
+ other failures.
See for more information.
diff --git a/doc/src/sgml/ref/pgtesttiming.sgml b/doc/src/sgml/ref/pgtesttiming.sgml
index 285f27f7c31..c450078291b 100644
--- a/doc/src/sgml/ref/pgtesttiming.sgml
+++ b/doc/src/sgml/ref/pgtesttiming.sgml
@@ -162,7 +162,7 @@ PostgreSQL documentation
instruction (used for EXPLAIN ANALYZE). At the end
of the output, the TSC frequency, which may either be
sourced from CPU information directly, or the alternate calibration
- mechanism are shown, as well as whether the TSC clock
+ mechanism is shown, as well as whether the TSC clock
source will be used by default.
diff --git a/doc/src/sgml/runtime.sgml b/doc/src/sgml/runtime.sgml
index d9984910cc4..69b349d54f6 100644
--- a/doc/src/sgml/runtime.sgml
+++ b/doc/src/sgml/runtime.sgml
@@ -2604,8 +2604,8 @@ openssl x509 -req -in server.csr -text -days 365 \
PostgreSQL can be configured for Server Name
Indication, SNI, using the
configuration parameter. PostgreSQL inspects the
- TLS hostname extension in the SSL connection handshake, and selects the
- right certificate, key and CA certificate to use for the connection based
+ TLS hostname extension in the SSL connection handshake and selects the
+ right certificate, key, and CA certificate to use for the connection based
on entries in the configuration file.
@@ -2665,8 +2665,8 @@ openssl x509 -req -in server.csr -text -days 365 \
Required
Certificate and key to use for connections to the host specified in
- the connection. Multiple hostnames can be defined by using a comma
- separated list. The certificate and key will be used for connections
+ the connection. Multiple hostnames can be defined by using a
+ comma-separated list. The certificate and key will be used for connections
to all hosts in the list.
diff --git a/doc/src/sgml/system-views.sgml b/doc/src/sgml/system-views.sgml
index 77202e2c765..45862ae5a1e 100644
--- a/doc/src/sgml/system-views.sgml
+++ b/doc/src/sgml/system-views.sgml
@@ -1167,7 +1167,7 @@ AND c1.path[c2.level] = c2.path[c2.level];
typetext
- The type of allocation. Possible values are segment,
+ The type of the allocation. Possible values are segment,
area, and hash, which correspond
to dynamic shared memory segments, areas, and hash tables, respectively.
@@ -1178,7 +1178,7 @@ AND c1.path[c2.level] = c2.path[c2.level];
sizeint8
- Size of the allocation in bytes. NULL for entries that failed
+ The size of the allocation in bytes. NULL for entries that failed
initialization.
@@ -4232,7 +4232,7 @@ SELECT * FROM pg_locks pl LEFT JOIN pg_prepared_xacts ppx
sizeint8
- Size of the allocation in bytes
+ The size of the allocation in bytes.
@@ -4241,7 +4241,7 @@ SELECT * FROM pg_locks pl LEFT JOIN pg_prepared_xacts ppx
allocated_sizeint8
- Size of the allocation in bytes including padding. For anonymous
+ The size of the allocation in bytes including padding. For anonymous
allocations, no information about padding is available, so the
size and allocated_size columns
will always be equal. Padding is not meaningful for free memory, so